hdoj 1896 Stones【优先队列】

2023-05-18,,

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1363    Accepted Submission(s): 850

Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 
Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 
Output
Just output one line for one test case, as described in the Description.
 
Sample Input

2

2

1 5

2 4

2
1 5
6 6

 
Sample Output

11
12

题意:每行的两个数据pi和Di分别代表石头所在的位置和所能扔出的距离,当石头是第奇数个是向外扔

当是第偶数个时绕过去,(之前扔过来的石头也参与运算)直至没有石头可扔  求出起点0到终点

的距离:

AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
int stone;
int dis;
friend bool operator< (node a,node b)
{
if(a.stone==b.stone)
return a.dis>b.dis;
else
return a.stone>b.stone;
}
};
int main()
{
int n,m,j,i,t;
scanf("%d",&t);
while(t--)
{
priority_queue<node>q;
node x,x1;
scanf("%d",&n);
for(i=0;i<n;i++)
{
int p,d;
scanf("%d%d",&p,&d);
x.stone=p;
x.dis=d;
q.push(x);
}
int ans=0;//判断是第奇数还是第偶数个石头
int sum;//记录总距离
while(!q.empty())
{
ans++;
x=q.top();
sum=x.stone;
if(ans&1)//如果是第奇数个石头则扔出去删除队首元素并
{ //将扔出去后的石头的 坐标 及可以扔出的距离入队
x1.stone=x.stone+x.dis;
x1.dis=x.dis;
q.pop();
q.push(x1);
}
else//第偶数个石头则直接删除队首元素
{
q.pop();
}
}
printf("%d\n",sum);
}
return 0;
}

  

hdoj 1896 Stones【优先队列】的相关教程结束。

《hdoj 1896 Stones【优先队列】.doc》

下载本文的Word格式文档,以方便收藏与打印。