A Simple Problem with Integers(树状数组HDU4267)

2023-05-02,,

A Simple Problem with Integers

Time Limit: 5000/1500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4494 Accepted Submission(s): 1384

Problem Description

Let A1, A2, … , AN be N elements. You need to deal with two kinds of operations. One type of operation is to add a given number to a few numbers in a given interval. The other is to query the value of some element.

Input

There are a lot of test cases.

The first line contains an integer N. (1 <= N <= 50000)

The second line contains N numbers which are the initial values of A1, A2, … , AN. (-10,000,000 <= the initial value of Ai <= 10,000,000)

The third line contains an integer Q. (1 <= Q <= 50000)

Each of the following Q lines represents an operation.

“1 a b k c” means adding c to each of Ai which satisfies a <= i <= b and (i - a) % k == 0. (1 <= a <= b <= N, 1 <= k <= 10, -1,000 <= c <= 1,000)

“2 a” means querying the value of Aa. (1 <= a <= N)

Output

For each test case, output several lines to answer all query operations.

Sample Input

4

1 1 1 1

14

2 1

2 2

2 3

2 4

1 2 3 1 2

2 1

2 2

2 3

2 4

1 1 4 2 1

2 1

2 2

2 3

2 4

Sample Output

1

1

1

1

1

3

3

1

2

3

4

1

Source

2012 ACM/ICPC Asia Regional Changchun Online

比赛的时候没有注意到k的值很小果断超时.

更新区间(a,b)中(i-a)%k==0的点其实就是更新区间(a,b)中i%k==a%k的值,所以可以用树状数组实现

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm> using namespace std; const int MAX = 55000; int FK[MAX][11][11]; int num[MAX]; int n,m; int lowbit(int x)
{
return x&(-x);
}
void update(int x,int k,int mod,int va)//更新摸为k,取模后为mod的区间的数组
{
while(x>0)
{
FK[x][k][mod]+=va;
x-=lowbit(x);
}
}
int Query(int x,int a)//查询a所在的区间的增加值
{
int s=0;
while(x<MAX)
{
for(int i=1;i<=10;i++)
{
s+=FK[x][i][a%i];
}
x+=lowbit(x);
}
return s;
} int main()
{
int flag,a,b,k,va;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
{
scanf("%d",&num[i]);
}
scanf("%d",&m);
memset(FK,0,sizeof(FK));
for(int i=1;i<=m;i++)
{
scanf("%d",&flag);
if(flag==1)
{
scanf("%d %d %d %d",&a,&b,&k,&va);
update(b,k,a%k,va);
update(a-1,k,a%k,-va);
}
else
{
scanf("%d",&a);
printf("%d\n",Query(a,a)+num[a]);
}
}
}
return 0;
}

A Simple Problem with Integers(树状数组HDU4267)的相关教程结束。

《A Simple Problem with Integers(树状数组HDU4267).doc》

下载本文的Word格式文档,以方便收藏与打印。