Harmonic Number (调和级数+欧拉常数)题解

2023-03-15,,

Harmonic Number

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

思路:

问问神奇海螺怎么套公式

代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<queue>
#include<cmath>
#include<string>
#include<map>
#include<stack>
#include<set>
#include<vector>
#include<iostream>
#include<algorithm>
#define INF 0x3f3f3f3f
#define ll long long
const int N=1e4+5;
const int MOD=1000;
const double C=0.57721566490153286060651209;
using namespace std;
double res[N];
int main(){
int T,num=1;
int n;
double ans;
res[1]=1;
for(int i=2;i<=10000;i++){
res[i]=res[i-1]+1.0/i;
}
scanf("%d",&T);
while(T--){
scanf("%d",&n);
if(n<=10000){
printf("Case %d: %.10lf\n",num++,res[n]);
}
else{
ans=log(n)+1.0/(2*n)+C;
printf("Case %d: %.10lf\n",num++,ans);
} }
return 0;
}

Harmonic Number (调和级数+欧拉常数题解的相关教程结束。

《Harmonic Number (调和级数+欧拉常数)题解.doc》

下载本文的Word格式文档,以方便收藏与打印。