PAT-1078 Hashing (散列表 二次探测法)

2022-12-19,,,

1078. Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum
size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers,
respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it
is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题目大意:此题给出散列表的大小msize以及要插入的数据n个,要求顺序输出每个数据在散列表中的索引。

主要思想:1.如果给出的msize不是素数,则要找到大于该值的最小素数;

 
              2.用二次探测法(quadratic probing)解决碰撞,而且只考虑正增长;

#include <iostream>
using namespace std;
bool marked[10010]; //注意9973的下一个素数是10007
//判断是否是素数的函数
bool is_prime(int x) {
if (x < 2) return false;
for (int i = 2; i * i <= x; i++)
if (x % i == 0)
return false;
return true;
} int main(void) {
int msize, n, num, i; cin >> msize >> n;
for (i = msize; ; i++) {
if (is_prime(i)) {
msize = i;
break;
}
}
for (i = 0; i < n; i++) {
cin >> num;
int h = num % msize; //初始散列位置
int hash = h;
bool flag = false; //是否散列成功
for (int k = 0; k < msize; k++) {
hash = (h + k * k) % msize; //二次探测法
if (!marked[hash]) { //成功找到位置
marked[hash] = true;
flag = true;
break;
}
}
if (flag) cout << hash;
else cout << "-";
if (i != n-1) cout << " ";
else cout << endl;
} return 0;
}

PAT-1078 Hashing (散列表 二次探测法)的相关教程结束。

《PAT-1078 Hashing (散列表 二次探测法).doc》

下载本文的Word格式文档,以方便收藏与打印。